import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)\\A(?:\\d{2}/\\d{2}/\\d{2}(?:\\d{2})?|−−DATE−−)\\s.*\\s\\p{Lu}{3}$";
final String string = "08/03/2020 NOVUS HOME Mortgage Company TRU\n"
+ " MORTGAGE\n"
+ " 07/08/2020 FACTUAL DATA Mortgage Reporter XPN\n"
+ " 07/08/2020 FCTUALDATA EFX\n"
+ " 07/08/2020 NOVUS HOME Mortgage Company TRU\n"
+ " MORTGAGE\n"
+ " 07/07/2020 CROSSCOUNTRY Mortgage Loan TRU\n"
+ " MORTGAG\n"
+ " 07/07/2020 FACTUAL DATA Mortgage Reporter XPN\n"
+ " 07/07/2020 FCTUALDATA EFX\n"
+ " 05/21/2020 CAP ONE NA Bank Credit Card XPN\n"
+ " 05/21/2020 CAPITAL ONE Credit Card TRU\n"
+ " 05/21/2020 CAPITALONE Bank EFX\n"
+ " 05/20/2020 CROSSCOUNTRY Mortgage Loan TRU\n"
+ " MORTGAG\n"
+ " 05/20/2020 FACTUAL DATA Mortgage Reporter XPN\n"
+ " 05/20/2020 FCTUALDATA EFX\n"
+ " 05/20/2020 FINGERHUT/WEBBANK Finance Company XPN\n"
+ " 05/07/2020 EMS EFX\n"
+ " 05/07/2020 GROW FINANCIAL CREDI Credit Bureau/Mortgage TRU\n"
+ " Processing\n"
+ " Co-Applicant\n"
+ " No inquiry records found.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}