using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*part).*?$";
string input = @"<instance_material symbol=""material_677part01_h502_w5"" target=""#material_677part01_h502_w5""/>
<instance_material symbol=""material_677"" target=""#material_677""/> ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}