re = /^(?!.*part).*?$/m
str = '<instance_material symbol="material_677part01_h502_w5" target="#material_677part01_h502_w5"/>
<instance_material symbol="material_677" target="#material_677"/> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end