import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*part).*?$";
final String string = "<instance_material symbol=\"material_677part01_h502_w5\" target=\"#material_677part01_h502_w5\"/>\n"
+ " <instance_material symbol=\"material_677\" target=\"#material_677\"/> ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}