using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?text""\s?:\s?""([\w\s]+).*?name""\s?:\s?""([\w\s]+)";
string input = @"'{""data"":""1233"",""image"":""dsfsdfsdfds"".""text"":""hello world"".""name"": ""java""}'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}