$re = '/.*?text"\s?:\s?"([\w\s]+).*?name"\s?:\s?"([\w\s]+)/m';
$str = '\'{"data":"1233","image":"dsfsdfsdfds"."text":"hello world"."name": "java"}\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);