package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?text"\s?:\s?"([\w\s]+).*?name"\s?:\s?"([\w\s]+)`)
var str = `'{"data":"1233","image":"dsfsdfsdfds"."text":"hello world"."name": "java"}'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}