#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)org.alluxio<name="*([a-zA-Z_\.]+)\.([0-9\.]+)"*,*[^:,\n]*><>(\w+)Rate"
Local $sString = "org.alluxio<name=Master.GetFingerprint.UFS:s3a:%2F%2Frzp-si-dashboard%2F.UFS_TYPE:s3, type=timers><>50thPercentile" & @CRLF & _
"org.alluxio<name=Master.registerMaster.User:alluxio" & @CRLF & _
"org.alluxio<name=Master.EmbeddedJournalSnapshotReplayTimer, type=timers><>50thPercentile" & @CRLF & _
"org.alluxio<name=Master.InodeCacheEvictions, type=counters><>Count" & @CRLF & _
"org.alluxio<name="Master.getConfigHash.User:trino:afd", type=counters><>Count" & @CRLF & _
"org.alluxio<name=Master.GetSpace.User:alluxio.UFS:s3:%2F%2Frzp-edh-prod%2Falluxio%2Falluxio-dev.UFS_TYPE:s3.fd, type=timers><>50thPercentile" & @CRLF & _
"org.alluxio<name=Master.GetSpace.User:alluxio.UFS:s3:%2F%2Frzp-edh-prod%2Falluxio%2Falluxio-dev.UFS_TYPE:s3.fd><>50thPercentile" & @CRLF & _
"org.alluxio<name=Master.JournalGainPrimacyTimer, type=timers><>50thPercentile" & @CRLF & _
"org.alluxio<name="Master.UfsSessionCount-Ufs:s3:%2F%2Frzp-prod-datum%2Fpa_sheets%2FXFinopsIncidentTracker%2FIncidentTracker"><>Count" & @CRLF & _
"org.alluxio<name=Worker.BytesReadRemoteThroughput.10.44.21.20, type=meters><>OneMinuteRate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")