import re
regex = re.compile(r"org.alluxio<name=\"*([a-zA-Z_\.]+)\.([0-9\.]+)\"*,*[^:,\n]*><>(\w+)Rate", flags=re.MULTILINE)
test_str = ("org.alluxio<name=Master.GetFingerprint.UFS:s3a:%2F%2Frzp-si-dashboard%2F.UFS_TYPE:s3, type=timers><>50thPercentile\n"
"org.alluxio<name=Master.registerMaster.User:alluxio\n"
"org.alluxio<name=Master.EmbeddedJournalSnapshotReplayTimer, type=timers><>50thPercentile\n"
"org.alluxio<name=Master.InodeCacheEvictions, type=counters><>Count\n"
"org.alluxio<name=\"Master.getConfigHash.User:trino:afd\", type=counters><>Count\n"
"org.alluxio<name=Master.GetSpace.User:alluxio.UFS:s3:%2F%2Frzp-edh-prod%2Falluxio%2Falluxio-dev.UFS_TYPE:s3.fd, type=timers><>50thPercentile\n"
"org.alluxio<name=Master.GetSpace.User:alluxio.UFS:s3:%2F%2Frzp-edh-prod%2Falluxio%2Falluxio-dev.UFS_TYPE:s3.fd><>50thPercentile\n"
"org.alluxio<name=Master.JournalGainPrimacyTimer, type=timers><>50thPercentile\n"
"org.alluxio<name=\"Master.UfsSessionCount-Ufs:s3:%2F%2Frzp-prod-datum%2Fpa_sheets%2FXFinopsIncidentTracker%2FIncidentTracker\"><>Count\n"
"org.alluxio<name=Worker.BytesReadRemoteThroughput.10.44.21.20, type=meters><>OneMinuteRate")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")