$re = '/^
(?:
-?\d+(?:\.\d+)?
(?:[+*/-]|$)
)+
(?<![+*/-])
$/mx';
$str = '53.22+22.11+10*555+62+55.2-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);