// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?:
-?\d+(?:\.\d+)?
(?:[+*/-]|$)
)+
(?<![+*/-])
$").unwrap();
let string = "53.22+22.11+10*555+62+55.2-3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}