using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\b\d{5}\b)(?:\D*|\d{1,4})*\K\d{5}(?!\d)";
string input = @";SUPER U CHARLY SUR MARNE;;;rte de Pavant CHARLY SUR MARNE Picardie 02310;Charly-sur-Marne;;;02310;;;;;;;;;;;;;;
test 123456
123456
1234
12345
test 1234 123456 124567 12345
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}