$re = '/^(?=.*\b\d{5}\b)(?:\D*|\d{1,4})*\K\d{5}(?!\d)/m';
$str = ';SUPER U CHARLY SUR MARNE;;;rte de Pavant CHARLY SUR MARNE Picardie 02310;Charly-sur-Marne;;;02310;;;;;;;;;;;;;;
test 123456
123456
1234
12345
test 1234 123456 124567 12345
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);