import re
regex = re.compile(r"^(?=.*\b\d{5}\b)(?:\D*|\d{1,4})*\K\d{5}(?!\d)", flags=re.MULTILINE)
test_str = (";SUPER U CHARLY SUR MARNE;;;rte de Pavant CHARLY SUR MARNE Picardie 02310;Charly-sur-Marne;;;02310;;;;;;;;;;;;;;\n"
"test 123456\n"
"123456\n"
"1234\n"
"12345\n"
"test 1234 123456 124567 12345\n\n"
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")