$re = '/(?<=user id\s*(-|:|is)\s)[A-Z].*"/m';
$str = 'user id - XXX XXX
user id- XXX XXX
user id XXX XXX
user id: XXX XXX
user id : XXX XXX
user id is XXX XXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);