using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\b(\w+)\b.*\b\1\b.*\b\1\b)(?!.*\b(\w+)\b(?<!\b\2\b.+)(?!.*\b\2\b))";
string input = @"1 1 2 2
100 10 10 100
A B B A
HELLO HELLO
1 2 1 1
DOG CAT DOG
100 100 10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}