$re = '/^(?!.*\b(\w+)\b.*\b\1\b.*\b\1\b)(?!.*\b(\w+)\b(?<!\b\2\b.+)(?!.*\b\2\b))/m';
$str = '1 1 2 2
100 10 10 100
A B B A
HELLO HELLO
1 2 1 1
DOG CAT DOG
100 100 10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);