import Foundation
let pattern = #"^(?!.*\b(\w+)\b.*\b\1\b.*\b\1\b)(?!.*\b(\w+)\b(?<!\b\2\b.+)(?!.*\b\2\b))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 1 2 2
100 10 10 100
A B B A
HELLO HELLO
1 2 1 1
DOG CAT DOG
100 100 10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)