import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<input.*?(?:id=\\\"emailaddress\\\".*?value=\\\"([^\"]+)|value=\\\"([^\"]+).*?id=\\\"emailaddress\\\")[^>]*>";
final String string = "<input type=\"text\" autocomplete=\"\" value=\"fname.lname@gmail.com\" name=\"confirmedEmailAddress\" id=\"emailaddress\" maxlength=\"60\" class=\"txt-box txtbox-m \" aria-describedby=\"\" aria-required=\"true\" disabled=\"disabled\">\n\n"
+ "<input type=\"text\" autocomplete=\"\" name=\"confirmedEmailAddress\" id=\"emailaddress\" maxlength=\"60\" value=\"fname.lname@gmail.com\" class=\"txt-box txtbox-m \" aria-describedby=\"\" aria-required=\"true\" disabled=\"disabled\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}