// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<input.*?(?:id=\"emailaddress\".*?value=\"([^"]+)|value=\"([^"]+).*?id=\"emailaddress\")[^>]*>"#).unwrap();
let string = "<input type=\"text\" autocomplete=\"\" value=\"fname.lname@gmail.com\" name=\"confirmedEmailAddress\" id=\"emailaddress\" maxlength=\"60\" class=\"txt-box txtbox-m \" aria-describedby=\"\" aria-required=\"true\" disabled=\"disabled\">
<input type=\"text\" autocomplete=\"\" name=\"confirmedEmailAddress\" id=\"emailaddress\" maxlength=\"60\" value=\"fname.lname@gmail.com\" class=\"txt-box txtbox-m \" aria-describedby=\"\" aria-required=\"true\" disabled=\"disabled\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}