const regex = /<input.*?(?:id=\"emailaddress\".*?value=\"([^"]+)|value=\"([^"]+).*?id=\"emailaddress\")[^>]*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input.*?(?:id=\\"emailaddress\\".*?value=\\"([^"]+)|value=\\"([^"]+).*?id=\\"emailaddress\\")[^>]*>', 'g')
const str = `<input type="text" autocomplete="" value="fname.lname@gmail.com" name="confirmedEmailAddress" id="emailaddress" maxlength="60" class="txt-box txtbox-m " aria-describedby="" aria-required="true" disabled="disabled">
<input type="text" autocomplete="" name="confirmedEmailAddress" id="emailaddress" maxlength="60" value="fname.lname@gmail.com" class="txt-box txtbox-m " aria-describedby="" aria-required="true" disabled="disabled">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}