using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.*)(ASP.NET_SessionId)(=.*))(?=SameSite)";
string input = @"Set-Cookie: ASP.NET_SessionId=k25obpe4pyz44qyvyacsajgv; path=/; HttpOnly; SameSite=Lax; secure";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}