$re = '/((.*)(ASP.NET_SessionId)(=.*))(?=SameSite)/m';
$str = 'Set-Cookie: ASP.NET_SessionId=k25obpe4pyz44qyvyacsajgv; path=/; HttpOnly; SameSite=Lax; secure';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);