use strict;
my $str = 'Set-Cookie: ASP.NET_SessionId=k25obpe4pyz44qyvyacsajgv; path=/; HttpOnly; SameSite=Lax; secure';
my $regex = qr/((.*)(ASP.NET_SessionId)(=.*))(?=SameSite)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}