#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^2$"
Local $sString = "# ___ ___ ___ ___ ___ " & @CRLF & _
"# | _ )_ ) __| / __| __ _ _ ___ ___ _ _ | _ \___ ___" & @CRLF & _
"# | _ \/ /\__ \ \__ \/ _| '_/ -_) -_) ' \| / -_|_-<" & @CRLF & _
"# |___/___|___/__|___/\__|_| \___\___|_||_|_|_\___/__/" & @CRLF & _
"# |_ _| __| \/ | _ \ | /_\_ _| __| " & @CRLF & _
"# | | | _|| |\/| | _/ |__ / _ \| | | _| " & @CRLF & _
"# |_| |___|_| |_|_| |____/_/ \_\_| |___| " & @CRLF & _
"# " & @CRLF & _
"# PLEASE MODIFY FOR YOUR OWN USAGE" & @CRLF & _
"# Playfield Screen resolution width/height" & @CRLF & _
"1920" & @CRLF & _
"1080" & @CRLF & _
"# Backglass Screen resolution width/height" & @CRLF & _
"1280" & @CRLF & _
"1024" & @CRLF & _
"# Define Backglass using Display Devicename screen number (\\.\DISPLAY)x or screen coordinates (@x) or screen index (=x)" & @CRLF & _
"2" & @CRLF & _
"# x position For the backglass relative To the upper left corner Of the Playfield screen" & @CRLF & _
"0" & @CRLF & _
"# y position For the backglass On the selected display (Normally left at 0)" & @CRLF & _
"0" & @CRLF & _
"# width/height Of the DMD area In pixels - For 3 screen setup" & @CRLF & _
"551" & @CRLF & _
"189" & @CRLF & _
"# X/Y position Of the DMD area relative To the upper left corner Of the backglass screen - For 3 screen setup" & @CRLF & _
"367" & @CRLF & _
"813" & @CRLF & _
"# Y-flip, flips the LED display upside down" & @CRLF & _
"0" & @CRLF & _
"# X/Y position pos When StartBackground Is active, relative To upper left corner Of Playfield ('Small' Button In the Options)" & @CRLF & _
"0" & @CRLF & _
"0" & @CRLF & _
"# width/height Of the backglass When StartBackground Is active" & @CRLF & _
"0" & @CRLF & _
"0" & @CRLF & _
"# C:\path\Frame (The path To the location where you have the background image)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")