import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^2$";
final String string = "# ___ ___ ___ ___ ___ \n"
+ "# | _ )_ ) __| / __| __ _ _ ___ ___ _ _ | _ \\___ ___\n"
+ "# | _ \\/ /\\__ \\ \\__ \\/ _| '_/ -_) -_) ' \\| / -_|_-<\n"
+ "# |___/___|___/__|___/\\__|_| \\___\\___|_||_|_|_\\___/__/\n"
+ "# |_ _| __| \\/ | _ \\ | /_\\_ _| __| \n"
+ "# | | | _|| |\\/| | _/ |__ / _ \\| | | _| \n"
+ "# |_| |___|_| |_|_| |____/_/ \\_\\_| |___| \n"
+ "# \n"
+ "# PLEASE MODIFY FOR YOUR OWN USAGE\n"
+ "# Playfield Screen resolution width/height\n"
+ "1920\n"
+ "1080\n"
+ "# Backglass Screen resolution width/height\n"
+ "1280\n"
+ "1024\n"
+ "# Define Backglass using Display Devicename screen number (\\\\.\\DISPLAY)x or screen coordinates (@x) or screen index (=x)\n"
+ "2\n"
+ "# x position For the backglass relative To the upper left corner Of the Playfield screen\n"
+ "0\n"
+ "# y position For the backglass On the selected display (Normally left at 0)\n"
+ "0\n"
+ "# width/height Of the DMD area In pixels - For 3 screen setup\n"
+ "551\n"
+ "189\n"
+ "# X/Y position Of the DMD area relative To the upper left corner Of the backglass screen - For 3 screen setup\n"
+ "367\n"
+ "813\n"
+ "# Y-flip, flips the LED display upside down\n"
+ "0\n"
+ "# X/Y position pos When StartBackground Is active, relative To upper left corner Of Playfield ('Small' Button In the Options)\n"
+ "0\n"
+ "0\n"
+ "# width/height Of the backglass When StartBackground Is active\n"
+ "0\n"
+ "0\n"
+ "# C:\\path\\Frame (The path To the location where you have the background image)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}