# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^2$"
test_str = ("# ___ ___ ___ ___ ___ \n"
"# | _ )_ ) __| / __| __ _ _ ___ ___ _ _ | _ \\___ ___\n"
"# | _ \\/ /\\__ \\ \\__ \\/ _| '_/ -_) -_) ' \\| / -_|_-<\n"
"# |___/___|___/__|___/\\__|_| \\___\\___|_||_|_|_\\___/__/\n"
"# |_ _| __| \\/ | _ \\ | /_\\_ _| __| \n"
"# | | | _|| |\\/| | _/ |__ / _ \\| | | _| \n"
"# |_| |___|_| |_|_| |____/_/ \\_\\_| |___| \n"
"# \n"
"# PLEASE MODIFY FOR YOUR OWN USAGE\n"
"# Playfield Screen resolution width/height\n"
"1920\n"
"1080\n"
"# Backglass Screen resolution width/height\n"
"1280\n"
"1024\n"
"# Define Backglass using Display Devicename screen number (\\\\.\\DISPLAY)x or screen coordinates (@x) or screen index (=x)\n"
"2\n"
"# x position For the backglass relative To the upper left corner Of the Playfield screen\n"
"0\n"
"# y position For the backglass On the selected display (Normally left at 0)\n"
"0\n"
"# width/height Of the DMD area In pixels - For 3 screen setup\n"
"551\n"
"189\n"
"# X/Y position Of the DMD area relative To the upper left corner Of the backglass screen - For 3 screen setup\n"
"367\n"
"813\n"
"# Y-flip, flips the LED display upside down\n"
"0\n"
"# X/Y position pos When StartBackground Is active, relative To upper left corner Of Playfield ('Small' Button In the Options)\n"
"0\n"
"0\n"
"# width/height Of the backglass When StartBackground Is active\n"
"0\n"
"0\n"
"# C:\\path\\Frame (The path To the location where you have the background image)\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.