package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)c1::(?P<valueTiger>[a-z]*).*?c2::(?P<valueAnimal>[a-z]*)`)
var str = `{{c1::tiger}} is a kind of {{c2::animal::something movable}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}