$re = '/c1::(?P<valueTiger>[a-z]*).*?c2::(?P<valueAnimal>[a-z]*)/m';
$str = '{{c1::tiger}} is a kind of {{c2::animal::something movable}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);