re = /c1::(?P<valueTiger>[a-z]*).*?c2::(?P<valueAnimal>[a-z]*)/m
str = '{{c1::tiger}} is a kind of {{c2::animal::something movable}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end