using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=-)0+(?=[1-9]\d*$)";
string substitution = @"";
string input = @"020200218-0PSS-001
020200218-0PSS-0010
020200218-0PSS-101";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}