$re = '/(?<=-)0+(?=[1-9]\d*$)/m';
$str = '020200218-0PSS-001
020200218-0PSS-0010
020200218-0PSS-101';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;