#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?!\w)[žŽ]olč iz žrela(?!\w)"
Local $sString = "Žolč iz žrela." & @CRLF & _
"Leading žolč iz žrela." & @CRLF & _
"Žolč iz žrela trailing." & @CRLF & _
"Leading žolč iz žrela trialing." & @CRLF & _
"Leadingžolč iz žrela." & @CRLF & _
"Žolč iz žrelatrailing."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")