$re = '/(?!\w)[žŽ]olč iz žrela(?!\w)/mi';
$str = 'Žolč iz žrela.
Leading žolč iz žrela.
Žolč iz žrela trailing.
Leading žolč iz žrela trialing.
Leadingžolč iz žrela.
Žolč iz žrelatrailing.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);