re = /(?!\w)[žŽ]olč iz žrela(?!\w)/mi
str = 'Žolč iz žrela.
Leading žolč iz žrela.
Žolč iz žrela trailing.
Leading žolč iz žrela trialing.
Leadingžolč iz žrela.
Žolč iz žrelatrailing.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end