using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(# the number at the beginning
[-+]? # optional leading sign
\d+# the digits to the left of the decimal
(?:\.\d+)? # an optional decimal amount
)
(#the start of the units
[a-zA-Z]+ # must be alphabetic
(?: # followed optionally by zero-or-more
\/[a-zA-Z]+ # slash-followed-by-text as in /hr
|
\^[-+]?\d+(?:\.\d+)? # a caret followed by our same/initial digit pattern
)*
)";
string input = @"Very much a stupid beginner question, but trying to make a regex expression which would take in ""5ms-1"", ""17km/h"" or ""9ms^-2"" etc. with these ambiguous units and ambiguous formats. Please help, I can't manage it
-5mph
6.8m/h
+8liters/hectacre^2
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}