const regex = new RegExp('(# the number at the beginning
[-+]? # optional leading sign
\\d+# the digits to the left of the decimal
(?:\\.\\d+)? # an optional decimal amount
)
(#the start of the units
[a-zA-Z]+ # must be alphabetic
(?: # followed optionally by zero-or-more
\\/[a-zA-Z]+ # slash-followed-by-text as in /hr
|
\\^[-+]?\\d+(?:\\.\\d+)? # a caret followed by our same/initial digit pattern
)*
)', 'gm')
const str = `Very much a stupid beginner question, but trying to make a regex expression which would take in "5ms-1", "17km/h" or "9ms^-2" etc. with these ambiguous units and ambiguous formats. Please help, I can't manage it
-5mph
6.8m/h
+8liters/hectacre^2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}