package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(# the number at the beginning
[-+]? # optional leading sign
\d+# the digits to the left of the decimal
(?:\.\d+)? # an optional decimal amount
)
(#the start of the units
[a-zA-Z]+ # must be alphabetic
(?: # followed optionally by zero-or-more
\/[a-zA-Z]+ # slash-followed-by-text as in /hr
|
\^[-+]?\d+(?:\.\d+)? # a caret followed by our same/initial digit pattern
)*
)`)
var str = `Very much a stupid beginner question, but trying to make a regex expression which would take in "5ms-1", "17km/h" or "9ms^-2" etc. with these ambiguous units and ambiguous formats. Please help, I can't manage it
-5mph
6.8m/h
+8liters/hectacre^2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}