package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([0-9]+)\]`)
var str = `Other conventions introduced by Doyle include the arch-criminal who is too clever for the official police to defeat, like Holmes's adversary Professor Moriarty, and the use of forensic science to solve cases.[1]
The Sherlock Holmes stories established crime fiction as a respectable genre popular with readers of all backgrounds, and Doyle's success inspired many contemporary detective stories.[174] Holmes influenced the creation of other "eccentric gentleman detective" characters, like Agatha Christie's fictional detective Hercule Poirot, introduced in 1920.[175]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}