use strict;
my $str = 'Other conventions introduced by Doyle include the arch-criminal who is too clever for the official police to defeat, like Holmes\'s adversary Professor Moriarty, and the use of forensic science to solve cases.[1]
The Sherlock Holmes stories established crime fiction as a respectable genre popular with readers of all backgrounds, and Doyle\'s success inspired many contemporary detective stories.[174] Holmes influenced the creation of other "eccentric gentleman detective" characters, like Agatha Christie\'s fictional detective Hercule Poirot, introduced in 1920.[175]';
my $regex = qr/\[([0-9]+)\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}