import Foundation
let pattern = #"\[([0-9]+)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Other conventions introduced by Doyle include the arch-criminal who is too clever for the official police to defeat, like Holmes's adversary Professor Moriarty, and the use of forensic science to solve cases.[1]
The Sherlock Holmes stories established crime fiction as a respectable genre popular with readers of all backgrounds, and Doyle's success inspired many contemporary detective stories.[174] Holmes influenced the creation of other "eccentric gentleman detective" characters, like Agatha Christie's fictional detective Hercule Poirot, introduced in 1920.[175]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)