using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\bbaz\b).*\b(?:foo|bar)\b";
string input = @"abc foo
123 xyz bar
abcd foo baz
pqr mnop bar baz
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}