re = /^(?!.*\bbaz\b).*\b(?:foo|bar)\b/m
str = 'abc foo
123 xyz bar
abcd foo baz
pqr mnop bar baz
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end