$re = '/^(?!.*\bbaz\b).*\b(?:foo|bar)\b/m';
$str = 'abc foo
123 xyz bar
abcd foo baz
pqr mnop bar baz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);