using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ \d](?:(?<=[ ])[ ]|\d){7}\d";
string input = @"123456789
kfasdf 3456789asdf
a 1
<< spaces
12345 789
1 9
a 678a";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}