import Foundation
let pattern = #"[ \d](?:(?<=[ ])[ ]|\d){7}\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
123456789
kfasdf 3456789asdf
a 1
<< spaces
12345 789
1 9
a 678a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)