re = /[ \d](?:(?<=[ ])[ ]|\d){7}\d/
str = '123456789
kfasdf 3456789asdf
a 1
<< spaces
12345 789
1 9
a 678a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end