#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^gallery/country/(?:.*[/.])?([a-zA-Z]{2})/?$"
Local $sString = "gallery/country" & @CRLF & _
"" & @CRLF & _
"gallery/country/" & @CRLF & _
"" & @CRLF & _
"gallery/country/ie" & @CRLF & _
"" & @CRLF & _
"gallery/country/ie/" & @CRLF & _
"" & @CRLF & _
"gallery/country/ireland" & @CRLF & _
"" & @CRLF & _
"gallery/country/ireland/" & @CRLF & _
"" & @CRLF & _
"gallery/country/ireland-love.ie" & @CRLF & _
"" & @CRLF & _
"gallery/country/ireland-love.ie/" & @CRLF & _
"" & @CRLF & _
"gallery/country/ireland.69-love.ie/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")