package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^gallery/country/(?:.*[/.])?([a-zA-Z]{2})/?$`)
var str = `gallery/country
gallery/country/
gallery/country/ie
gallery/country/ie/
gallery/country/ireland
gallery/country/ireland/
gallery/country/ireland-love.ie
gallery/country/ireland-love.ie/
gallery/country/ireland.69-love.ie/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}