$re = '@^gallery/country/(?:.*[/.])?([a-zA-Z]{2})/?$@m';
$str = 'gallery/country
gallery/country/
gallery/country/ie
gallery/country/ie/
gallery/country/ireland
gallery/country/ireland/
gallery/country/ireland-love.ie
gallery/country/ireland-love.ie/
gallery/country/ireland.69-love.ie/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);